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Lampiran 2  
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Lampiran 3 

Data latih cadangan hidrokarbon pada Sumur X suatu lapangan 

No Data 
Volume Bulk 

(acre-feet) 
Saturasi Hidrokarbon 

(fraksi) 
Porositas Batuan 

(fraksi) 
BOI 

(BBL/STB) 
OOIP 
(STB) 

1 H-II 11.217,46 0,6251 0,18409 1,2091 8.282.544 
2 H-III 25.725,86 0,47702 0,18223 1,2091 14.348.827 
3 H-IV 3.582,1 0,20125 0,15629 1,13 773.530 
4 H1-I 4.249,94 0,62552 0,18608 1,217 3.153.404 
5 H1-II 16.135,97 0,59424 0,14258 1,217 8.715.183 
6 H1-IV 15.974,84 0,00406 0,0969 1,131 43.089 
7 I1-II 34.006,78 0,59952 0,08872 1,293 10.852.718 
8 I1-III&IV 32.815,35 0,59471 0,14475 1,293 16.949.667 
9 L-II 37.474,42 0,25731 0,10536 1,209 6.519.170 
10 L-III 85.884,02 0,21607 0,11247 1,209 13.392.086 
11 L-IV 41.339,26 0,21161 0,14009 1,209 7.863.702 
12 CGL.A-A1 24.189,48 0,67281 0,20269 1,496 17.106.615 
13 CGL.A-A2 20.426,19 0,56191 0,19252 1,309 13.096.296 
14 CGL.B-B1 40.507,73 0,67522 0,20581 1,496 29.191.998 
15 CGL.B-B2 26.988,4 0,56191 0,20198 1,309 18.153.908 
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Lampiran 4 

Lima belas aturan fuzzy berdasarkan data latih 

1. Jika �� adalah � dan �� adalah � dan ��������� adalah � dan ��� adalah � maka ���� adalah 1. 

2. Jika �� adalah � dan �� adalah � dan ��������� adalah � dan ��� adalah � maka ���� adalah 2. 

3. Jika �� adalah � dan �� adalah � dan ��������� adalah � dan ��� adalah � maka ���� adalah 3. 

4. Jika �� adalah � dan �� adalah � dan ��������� adalah � dan ��� adalah � maka ���� adalah 4. 

5. Jika �� adalah � dan �� adalah � dan ��������� adalah � dan ��� adalah � maka ���� adalah 5. 

6. Jika �� adalah � dan �� adalah � dan ��������� adalah � dan ��� adalah � maka ���� adalah 6. 

7. Jika �� adalah � dan �� adalah � dan ��������� adalah � dan ��� adalah � maka ���� adalah 7. 

8. Jika �� adalah � dan �� adalah � dan ��������� adalah � dan ��� adalah � maka ���� adalah 8. 

9. Jika �� adalah � dan �� adalah � dan ��������� adalah � dan ��� adalah � maka ���� adalah 9. 

10. Jika �� adalah � dan �� adalah � dan ��������� adalah � dan ��� adalah � maka ���� adalah 10. 

11. Jika �� adalah � dan �� adalah � dan ��������� adalah � dan ��� adalah � maka ���� adalah 11. 

12. Jika �� adalah � dan �� adalah � dan ��������� adalah � dan ��� adalah � maka ���� adalah 12. 

13. Jika �� adalah � dan �� adalah � dan ��������� adalah � dan ��� adalah � maka ���� adalah 13. 

14. Jika �� adalah � dan �� adalah � dan ��������� adalah � dan ��� adalah � maka ���� adalah 14. 

15. Jika �� adalah � dan �� adalah � dan ��������� adalah � dan ��� adalah � maka ���� adalah 15. 
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Lampiran 5 

Tahapan-tahapan pembuatan model fuzzy Sugeno orde nol dengan MATLAB 

R2010b: 

1. Buka program MATLAB R2010b. 

2. Ketikkan fuzzy pada command window, maka akan muncul tampilan FIS 

editor seperti pada Gambar 1.. 

 

Gambar 1. FIS editor metode Mamdani 

3. Pilih menu File>New FIS>Sugeno, kemudian akan muncul tampilan seperti 

pada Gambar 2.. 
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Gambar 2. FIS editor metode Sugeno 

4. Simpan file dengan nama hitungOOIP, yaitu dengan memilih menu 

File>Export>To File. Metode Sugeno pada FIS disetel dengan fungsi 

implikasi min, fungsi agregasi max, dan defuzzifikasi wtaver (weighted 

average) sehingga tidak perlu diubah. 

5. Pada penelitian ini digunakan empat variabel input dan sebuah variabel 

output. Pilih menu Edit>Add Variable>Input untuk menambah satu variabel 

input. Ulangi tahapan ini sebanyak tiga kali sehingga terbentuk empat 

variabel input dan satu variabel output seperti pada Gambar 3.. 
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Gambar 3. FIS editor dengan empat variabel input 
dan satu variabel output 

6. Pilih menu Edit>Membership Functions untuk membuka membership 

function editor. Buat fungsi keanggotaan setiap variabel input dan output 

seperti pada Gambar 4. dengan melakukan tahapan-tahapan di bawah ini. 

Tentukan interval variabel pada range, maka display range akan mengikuti. 

Pilih menu Edit>Add MFs untuk membuat atau menambah fungsi 

keanggotaan. Pada Current Membership Function tentukan nama, tipe, dan 

parameternya. Pada variabel input, Vb menggunakan empat himpunan fuzzy 

sedangkan Sh, Porositas, dan BOI menggunakan tiga himpunan fuzzy. 

Lakukan tahapan yang sama pada variabel output. Namun, pilih tipe 

constant pada Current Membership Function karena metode yang 

digunakan adalah Sugeno orde nol. 
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Gambar 4. Fungsi Keanggotaan variabel input Vb 

7. Pilih Edit>Rules untuk membuat aturan fuzzy. Tahapan yang digunakan, 

yaitu pilih satu himpunan fuzzy pada setiap variabel. FIS disetel dengan and 

pada connection dan 1 pada weight, sehingga tidak perlu diubah. Kemudian 

klik Add rule untuk menambah aturan fuzzy. Ulangi tahapan ini sebanyak 

empat belas kali sehingga terbentuk lima belas aturan fuzzy seperti pada 

Gambar 5.. 

 

Gambar 5. Lima belas aturan fuzzy yang terbentuk 
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8. Evaluasi data dilakukan dengan rule viewer. Pilih View>Rules untuk 

membuka tampilan rule viewer. Pada input yang terletak di bagian bawah 

tampilan, ketikkan data yang akan dievaluasi. Kemudian tekan tombol 

Enter, maka akan muncul hasil output–nya pada bagian atas kanan seperti 

pada Gambar 6.. 

 

Gambar 6. Hasil evaluasi data pada FIS 

Pada evaluasi data jumlah besar, lebih efisien menggunakan perintah evalfis 

pada command window seperti pada Gambar 7.. 
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Gambar 7. Evaluasi data pada command window 

9. Saat akan keluar dari program, maka akan muncul kotak dialog seperti pada 

Gambar 8.. Pilih “Yes” untuk menyimpan perubahan yang dilakukan 

selama memodifikasi program FIS. 

 

Gambar 8. Kotak dialog 

 

 

 

 

 

 



64 
 

Lampiran 6 

Script MATLAB pada FIS 

[System] 
Name='REVISI7' 
Type='sugeno' 
Version=2.0 
NumInputs=4 
NumOutputs=1 
NumRules=15 
AndMethod='prod' 
OrMethod='probor' 
ImpMethod='prod' 
AggMethod='sum' 
DefuzzMethod='wtaver' 
  
[Input1] 
Name='Vb' 
Range=[0 100000] 
NumMFs=4 
MF1='A':'trimf',[0 0 11000] 
MF2='B':'trimf',[7000 20000 32000] 
MF3='C':'trimf',[18000 30000 50000] 
MF4='D':'trapmf',[34000 40000 100000 100000] 
  
[Input2] 
Name='Sh' 
Range=[0 1] 
NumMFs=3 
MF1='A':'trimf',[0 0 0.6] 
MF2='B':'trimf',[0.2 0.6 0.62] 
MF3='C':'trimf',[0.5 1 1] 
  
[Input3] 
Name='Porositas' 
Range=[0 0.4] 
NumMFs=3 
MF1='A':'trimf',[0 0 0.17] 
MF2='B':'trimf',[0.09 0.16 0.2] 
MF3='C':'trimf',[0.18 0.2 0.4] 
  
[Input4] 
Name='BOI' 
Range=[1 1.5] 
NumMFs=3 
MF1='A':'trimf',[1 1 1.22] 
MF2='B':'trimf',[1.1 1.3 1.35] 
MF3='C':'trimf',[1.2 1.32 1.5] 
  
[Output1] 
Name='OOIP' 
Range=[0 1] 
NumMFs=15 
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MF1='1':'constant',[8282544] 
MF2='2':'constant',[14348827] 
MF3='3':'constant',[773530] 
MF4='4':'constant',[3153404] 
MF5='5':'constant',[8715183] 
MF6='6':'constant',[43089] 
MF7='7':'constant',[10852718] 
MF8='8':'constant',[16949667] 
MF9='9':'constant',[6519170] 
MF10='10':'constant',[13392086] 
MF11='11':'constant',[7863702] 
MF12='12':'constant',[17106615] 
MF13='13':'constant',[13096296] 
MF14='14':'constant',[29191998] 
MF15='15':'constant',[18153908] 
  
[Rules] 
2 3 2 2, 1 (1) : 1 
3 2 2 2, 2 (1) : 1 
1 1 2 1, 3 (1) : 1 
1 3 2 2, 4 (1) : 1 
2 2 2 2, 5 (1) : 1 
2 1 1 1, 6 (1) : 1 
3 2 1 2, 7 (1) : 1 
3 2 2 2, 8 (1) : 1 
3 1 1 2, 9 (1) : 1 
4 1 1 2, 10 (1) : 1 
4 1 2 2, 11 (1) : 1 
2 3 3 3, 12 (1) : 1 
2 2 3 3, 13 (1) : 1 
4 3 3 3, 14 (1) : 1 
3 2 3 3, 15 (1) : 1 
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Lampiran 7 

Script MATLAB pada GUI 

function varargout = hitungOOIP(varargin) 
% HITUNGOOIP MATLAB code for hitungOOIP.fig 
%      HITUNGOOIP, by itself, creates a new HITUNGOOIP or raises 
the existing 
%      singleton*. 
% 
%      H = HITUNGOOIP returns the handle to a new HITUNGOOIP or 
the handle to 
%      the existing singleton*. 
% 
%      HITUNGOOIP('CALLBACK',hObject,eventData,handles,...) calls 
the local 
%      function named CALLBACK in HITUNGOOIP.M with the given 
input arguments. 
% 
%      HITUNGOOIP('Property','Value',...) creates a new HITUNGOOIP 
or raises the 
%      existing singleton*.  Starting from the left, property 
value pairs are 
%      applied to the GUI before hitungOOIP_OpeningFcn gets 
called.  An 
%      unrecognized property name or invalid value makes property 
application 
%      stop.  All inputs are passed to hitungOOIP_OpeningFcn via 
varargin. 
% 
%      *See GUI Options on GUIDE's Tools menu.  Choose "GUI allows 
only one 
%      instance to run (singleton)". 
% 
% See also: GUIDE, GUIDATA, GUIHANDLES 
  
% Edit the above text to modify the response to help hitungOOIP 
  
% Last Modified by GUIDE v2.5 22-Apr-2016 00:52:53 
  
% Begin initialization code - DO NOT EDIT 
gui_Singleton = 1; 
gui_State = struct('gui_Name',       mfilename, ... 
                   'gui_Singleton',  gui_Singleton, ... 
                   'gui_OpeningFcn', @hitungOOIP_OpeningFcn, ... 
                   'gui_OutputFcn',  @hitungOOIP_OutputFcn, ... 
                   'gui_LayoutFcn',  [] , ... 
                   'gui_Callback',   []); 
if nargin && ischar(varargin{1}) 
    gui_State.gui_Callback = str2func(varargin{1}); 
end 
  
if nargout 
    [varargout{1:nargout}] = gui_mainfcn(gui_State, varargin{:}); 
else 
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    gui_mainfcn(gui_State, varargin{:}); 
end 
% End initialization code - DO NOT EDIT 
  
% --- Executes just before hitungOOIP is made visible. 
function hitungOOIP_OpeningFcn(hObject, eventdata, handles, 
varargin) 
% This function has no output args, see OutputFcn. 
% hObject    handle to figure 
% eventdata  reserved - to be defined in a future version of 
MATLAB 
% handles    structure with handles and user data (see GUIDATA) 
% varargin   command line arguments to hitungOOIP (see VARARGIN) 
  
% Choose default command line output for hitungOOIP 
handles.output = hObject; 
  
% Update handles structure 
guidata(hObject, handles); 
  
% UIWAIT makes hitungOOIP wait for user response (see UIRESUME) 
% uiwait(handles.figure1); 
  
% --- Outputs from this function are returned to the command line. 
function varargout = hitungOOIP_OutputFcn(hObject, eventdata, 
handles)  
% varargout  cell array for returning output args (see VARARGOUT); 
% hObject    handle to figure 
% eventdata  reserved - to be defined in a future version of 
MATLAB 
% handles    structure with handles and user data (see GUIDATA) 
  
% Get default command line output from handles structure 
varargout{1} = handles.output; 
   
% --- Executes on button press in run. 
function run_Callback(hObject, eventdata, handles) 
% hObject    handle to run (see GCBO) 
% eventdata  reserved - to be defined in a future version of 
MATLAB 
% handles    structure with handles and user data (see GUIDATA) 
vb=str2double(get(handles.vb,'string')); 
sh=str2double(get(handles.sh,'string')); 
por_eff=str2double(get(handles.por_eff,'string')); 
boi=str2double(get(handles.boi,'string')); 
a=readfis('program'); 
out=evalfis([vb sh por_eff boi], a) 
  
if vb==11217.46&&sh==0.6251&&por_eff==0.18409&&boi==1.2091 
set(handles.ket,'string','Nilai aktual OOIP = 8282544 sehingga 
nilai MAPE = 7.11%'); 
else if vb==25725.86&&sh==0.47702&&por_eff==0.18223&&boi==1.2091 
set(handles.ket,'string','Nilai aktual OOIP = 14348827 sehingga 
nilai MAPE = 4.55%'); 
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else if vb==3582.1&&sh==0.20125&&por_eff==0.15629&&boi==1.13 
set(handles.ket,'string','Nilai aktual OOIP = 773530 sehingga 
nilai MAPE = 0%'); 
else if vb==4249.94&&sh==0.62552&&por_eff==0.18608&&boi==1.217 
set(handles.ket,'string','Nilai aktual OOIP = 3153404 sehingga 
nilai MAPE = 0%'); 
else if vb==16135.97&&sh==0.59424&&por_eff==0.14258&&boi==1.217 
set(handles.ket,'string','Nilai aktual OOIP = 8715183 sehingga 
nilai MAPE = 0.8%'); 
else if vb==15974.84&&sh==0.00406&&por_eff==0.0969&&boi==1.131 
set(handles.ket,'string','Nilai aktual OOIP = 43089 sehingga nilai 
MAPE = 0%'); 
else if vb==34006.78&&sh==0.59952&&por_eff==0.08872&&boi==1.293 
set(handles.ket,'string','Nilai aktual OOIP = 10852718 sehingga 
nilai MAPE = 0.03%'); 
else if vb==32815.35&&sh==0.59471&&por_eff==0.14475&&boi==1.293 
set(handles.ket,'string','Nilai aktual OOIP = 16949667 sehingga 
nilai MAPE = 10.17%'); 
else if vb==37474.42&&sh==0.25731&&por_eff==0.10536&&boi==1.209 
set(handles.ket,'string','Nilai aktual OOIP = 6519170 sehingga 
nilai MAPE = 55.26%'); 
else if vb==85884.02&&sh==0.21607&&por_eff==0.11247&&boi==1.209 
set(handles.ket,'string','Nilai aktual OOIP = 13392086 sehingga 
nilai MAPE = 20.1%'); 
else if vb==41339.26&&sh==0.21161&&por_eff==0.14009&&boi==1.209 
set(handles.ket,'string','Nilai aktual OOIP = 7863702 sehingga 
nilai MAPE = 13.96%'); 
else if vb==24189.48&&sh==0.67281&&por_eff==0.20269&&boi==1.496 
set(handles.ket,'string','Nilai aktual OOIP = 17106615 sehingga 
nilai MAPE = 0%'); 
else if vb==20426.19&&sh==0.56191&&por_eff==0.19252&&boi==1.309 
set(handles.ket,'string','Nilai aktual OOIP = 13096296 sehingga 
nilai MAPE = 2.33%'); 
else if vb==40507.73&&sh==0.67522&&por_eff==0.20581&&boi==1.496 
set(handles.ket,'string','Nilai aktual OOIP = 29191998 sehingga 
nilai MAPE = 0%'); 
else if vb==26988.4&&sh==0.56191&&por_eff==0.20198&&boi==1.309 
set(handles.ket,'string','Nilai aktual OOIP = 18153908 sehingga 
nilai MAPE = 9.78%'); 
else set(handles.ket,'string','Nilai aktual OOIP tidak 
ditemukan'); 
end                                                                 
end 
end 
end 
end 
end 
end 
end 
end 
end 
end 
end 
end 
end 
end 
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set(handles.ooip,'string',out); 
  
% --- Executes on button press in exit. 
function exit_Callback(hObject, eventdata, handles) 
% hObject    handle to exit (see GCBO) 
% eventdata  reserved - to be defined in a future version of 
MATLAB 
% handles    structure with handles and user data (see GUIDATA) 
close 
  
function vb_Callback(hObject, eventdata, handles) 
% hObject    handle to vb (see GCBO) 
% eventdata  reserved - to be defined in a future version of 
MATLAB 
% handles    structure with handles and user data (see GUIDATA) 
  
% Hints: get(hObject,'String') returns contents of vb as text 
%        str2double(get(hObject,'String')) returns contents of vb 
as a double 
 
% --- Executes during object creation, after setting all 
properties. 
function vb_CreateFcn(hObject, eventdata, handles) 
% hObject    handle to vb (see GCBO) 
% eventdata  reserved - to be defined in a future version of 
MATLAB 
% handles    empty - handles not created until after all 
CreateFcns called 
  
% Hint: edit controls usually have a white background on Windows. 
%       See ISPC and COMPUTER. 
if ispc && isequal(get(hObject,'BackgroundColor'), 
get(0,'defaultUicontrolBackgroundColor')) 
    set(hObject,'BackgroundColor','white'); 
end  
  
function sh_Callback(hObject, eventdata, handles) 
% hObject    handle to sh (see GCBO) 
% eventdata  reserved - to be defined in a future version of 
MATLAB 
% handles    structure with handles and user data (see GUIDATA) 
  
% Hints: get(hObject,'String') returns contents of sh as text 
%        str2double(get(hObject,'String')) returns contents of sh 
as a double 
 
% --- Executes during object creation, after setting all 
properties. 
function sh_CreateFcn(hObject, eventdata, handles) 
% hObject    handle to sh (see GCBO) 
% eventdata  reserved - to be defined in a future version of 
MATLAB 
% handles    empty - handles not created until after all 
CreateFcns called 
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% Hint: edit controls usually have a white background on Windows. 
%       See ISPC and COMPUTER. 
if ispc && isequal(get(hObject,'BackgroundColor'), 
get(0,'defaultUicontrolBackgroundColor')) 
    set(hObject,'BackgroundColor','white'); 
end 
 
function por_eff_Callback(hObject, eventdata, handles) 
% hObject    handle to por_eff (see GCBO) 
% eventdata  reserved - to be defined in a future version of 
MATLAB 
% handles    structure with handles and user data (see GUIDATA) 
  
% Hints: get(hObject,'String') returns contents of por_eff as text 
%        str2double(get(hObject,'String')) returns contents of 
por_eff as a double 
 
% --- Executes during object creation, after setting all 
properties. 
function por_eff_CreateFcn(hObject, eventdata, handles) 
% hObject    handle to por_eff (see GCBO) 
% eventdata  reserved - to be defined in a future version of 
MATLAB 
% handles    empty - handles not created until after all 
CreateFcns called 
  
% Hint: edit controls usually have a white background on Windows. 
%       See ISPC and COMPUTER. 
if ispc && isequal(get(hObject,'BackgroundColor'), 
get(0,'defaultUicontrolBackgroundColor')) 
    set(hObject,'BackgroundColor','white'); 
end 
 
function boi_Callback(hObject, eventdata, handles) 
% hObject    handle to boi (see GCBO) 
% eventdata  reserved - to be defined in a future version of 
MATLAB 
% handles    structure with handles and user data (see GUIDATA) 
  
% Hints: get(hObject,'String') returns contents of boi as text 
%        str2double(get(hObject,'String')) returns contents of boi 
as a double 
 
% --- Executes during object creation, after setting all 
properties. 
function boi_CreateFcn(hObject, eventdata, handles) 
% hObject    handle to boi (see GCBO) 
% eventdata  reserved - to be defined in a future version of 
MATLAB 
% handles    empty - handles not created until after all 
CreateFcns called 
  
% Hint: edit controls usually have a white background on Windows. 
%       See ISPC and COMPUTER. 
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if ispc && isequal(get(hObject,'BackgroundColor'), 
get(0,'defaultUicontrolBackgroundColor')) 
    set(hObject,'BackgroundColor','white'); 
end 
 
% --- Executes on button press in reset. 
function reset_Callback(hObject, eventdata, handles) 
% hObject    handle to reset (see GCBO) 
% eventdata  reserved - to be defined in a future version of 
MATLAB 
% handles    structure with handles and user data (see GUIDATA) 
set(handles.vb,'string',''); 
set(handles.sh,'string',''); 
set(handles.por_eff,'string',''); 
set(handles.boi,'string',''); 
set(handles.ooip,'string','0'); 
set(handles.ket,'string','Keterangan'); 
 
function ket_Callback(hObject, eventdata, handles) 
% hObject    handle to ket (see GCBO) 
% eventdata  reserved - to be defined in a future version of 
MATLAB 
% handles    structure with handles and user data (see GUIDATA) 
  
% Hints: get(hObject,'String') returns contents of ket as text 
%        str2double(get(hObject,'String')) returns contents of ket 
as a double 
 
% --- Executes during object creation, after setting all 
properties. 
function ket_CreateFcn(hObject, eventdata, handles) 
% hObject    handle to ket (see GCBO) 
% eventdata  reserved - to be defined in a future version of 
MATLAB 
% handles    empty - handles not created until after all 
CreateFcns called 
  
% Hint: edit controls usually have a white background on Windows. 
%       See ISPC and COMPUTER. 
if ispc && isequal(get(hObject,'BackgroundColor'), 
get(0,'defaultUicontrolBackgroundColor')) 
    set(hObject,'BackgroundColor','white'); 
end 
 
 
 
 
Keterangan:  Script ini dimodifikasi dari script membuat GUI pada logika fuzzy 

pada http://komputasirobotic.blogspot.co.id/2013/07/membuat-gui-
untuk-logika-fuzzy.html (2013) dan script Matlab diagnosis kanker 
payudara pada GUI pada skripsi Kurrotul A’yun (2015). 

.
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Lampiran 8 

Tahapan-tahapan visualisasi model fuzzy yang telah dibangun dengan GUI: 

1. Ketikkan guide pada command window yang ada pada MATLAB R2010b, 

maka akan muncul tampilan seperti pada Gambar 1.. 

 

Gambar 1. Tampilan awal GUI: GUIDE Quick Start 

2. Pilih Blank GUI (Default) pada Create New GUI lalu pilih OK. Kemudian 

akan muncul tampilan seperti pada Gambar 2.. 

 

Gambar 2. Layar default GUI 
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3. Simpan file dengan nama hitungOOIP, yaitu dengan memilih menu 

File>Save As. Buat rancangan layar aplikasi GUI sesuai tahapan-tahapan 

yang telah dijelaskan pada BAB III Sub-bab C, maka akan muncul tampilan 

seperti pada Gambar 3.. 

 

Gambar 3. Rancangan tampilan pada GUI 

4. Setelah rancangan selesai dibuat, tahapan selanjutnya adalah menyusun 

script MATLAB pada GUI dengan mengklik tombol M-file Editor pada 

toolbar. Script visualisasi model fuzzy dengan GUI disajikan pada 

Lampiran 5. 

5. Terakhir, melihat hasil program dan mengoperasikannya. Klik tombol Run 

Figure atau menekan tombol Ctrl+T secara bersamaan untuk melihat hasil 

program yang berupa tampilan GUI (Gambar 4.). 

 

Gambar 4. Tampilan visualisasi model fuzzy dengan GUI 
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